Jump to content
Sign in to follow this  

Turn Signal issue

Recommended Posts

Just noticed something this morning. The right front turn signal stays lit (non-flashing) whenever the key is on. When I switch the turn signal to the right the right front turn signal flashes normally as does the right rear. The left turn signals front and back work as expected. I don't know how long it's been doing this. I haven't looked into this yet. Has anyone seen this before?

 

Thanks,

Larry

Share this post


Link to post
Share on other sites

Just noticed something this morning. The right front turn signal stays lit (non-flashing) whenever the key is on. When I switch the turn signal to the right the right front turn signal flashes normally as does the right rear. The left turn signals front and back work as expected. I don't know how long it's been doing this. I haven't looked into this yet. Has anyone seen this before?

 

Thanks,

Larry

 

they take a dual filament bulb and both the fronts should stay on with just the key on as they are running/marker lights. If you have one that is not lite then it needs replaced. 

  • Like 2

Share this post


Link to post
Share on other sites

What Gnath said is correct. The light that isn't staying on is the issue.

 

Doe sit look like this? (sorry, not a CRFL but same idea)

d6DVWfUl.png

 

 

It should look like this:

 

jt421TMl.png

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...