Jump to content
Sign in to follow this  

rm 80 help

Recommended Posts

hey everyone just got a 99 rm80 i had it running then slowly started to die.  now i have a hard time starting it and the overflow tube on the carb leaks gas when the petcock in on.  also can use car oil to mix with gas?  thansk for the help.

Share this post


Link to post
Share on other sites

Don't use automotive oil as premix oil. Use 2stroke oil. As for the the carb a couple things to look at would be the float height and the float valve. Do you have the manual for the bike?

Share this post


Link to post
Share on other sites

Don't use automotive oil as premix oil. Use 2stroke oil. As for the the carb a couple things to look at would be the float height and the float valve. Do you have the manual for the bike?

 

no i do not have a manual.  is there a pdf one avalible?  i see the auto zone carries 2 stroke oil is spectrum any good?

Share this post


Link to post
Share on other sites

OK. I have a manual, I can scan it this eve. I can't speak to spectrum whether or not its good. I have used belray and amsoil and like both castrol is OK in a pinch. Everyone has a different opinion on oil though. Its also important to avoid mixing brands of oil too as it can become gummy. 2t oil is designed to burn off whereas 4cycle oil isn't and you will gum up all the ports and internals.

Share this post


Link to post
Share on other sites

OK. I have a manual, I can scan it this eve. I can't speak to spectrum whether or not its good. I have used belray and amsoil and like both castrol is OK in a pinch. Everyone has a different opinion on oil though. Its also important to avoid mixing brands of oil too as it can become gummy. 2t oil is designed to burn off whereas 4cycle oil isn't and you will gum up all the ports and internals.

 

 

excellent thank you for your help.  also i s there a thread for basic 2 stroke maintance for rm80's.  also the first 2stroke i have owned i have been riding 4 strokes for awhile.

Share this post


Link to post
Share on other sites

also what about reeds can they cause hard starts?

 

i just checked out the reeds they look fine no breaks or cracks.

Edited by usererror

Share this post


Link to post
Share on other sites

I've been trying to scan this manual and my scanner is ef'd up. The reeds could cause it but if they are not cracked or chipped they shouldn't be the prob.

Share this post


Link to post
Share on other sites

For a properly done compression test, start with a clean filter and hold the throttle wide open while kicking it over till it stops climbing. A good reading is somewhere above 120psi.

Share this post


Link to post
Share on other sites

well after many exhausting kicks the gauge stopped at 90psi and would not go any higher than that.  i assume that my rings are bad. 

Share this post


Link to post
Share on other sites

Yeah 90 is on the low side but should still run. That is where my sons bike was before doing the top end. Rings may be worn or just stuck.

 

that is what i was thinking.  shoud at least still try to run or make a attempt to anyways but i get nothing other legs workouts.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...