Jump to content
Sign in to follow this  

Milky oil 05 yz250f

Recommended Posts

Before anyone suggests I will state it's not it's not the water pump seals. I just replaced both seals and bearing. Put it all back together and oil is still milky. Is there something I missed?? I have the crankcase cover removed and inspected and everything seems to be in tact, no metal shavings no missing o rings gaskets. All seems normal expect oil is milky.

I just recently bought the bike from a buddy and I noticed it was running lean as hell so I broke the carb down cleaned and found pilot was clogged but all that was fixed plus it had coolant in it when I checked all that. So I'm afraid that he may have ran it like that for too long and did some serious damage. Fingers crossed but either way I got a hell of a deal on the bike so no loss really. But any suggestions where to look with out tearing engine apart would be much appreciated. Thanks

Share this post


Link to post
Share on other sites

My head gasket leaked after putting my engine back together and the oil got milky. It took at least 5 or 6 oil changes before it started looking normal.

  • Like 1

Share this post


Link to post
Share on other sites

Oh man.. actually that makes sense. Could just still be alot of water in the system that just needs flushed out. I'm gonna get some cheap oil and try it. Thanks!

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...