Jump to content
Sign in to follow this  

Battery loosing charge

Recommended Posts

I have a cbr250rr was fine for the first few days of owning it but then it died one night, roll starts fine if i ride for 30 mins stop it and try to start it will start but if i stop it and go inside for a drink and a snack it will be dead. used a charge to charge the battery to full and started instantly went back 3 hoursish later and inabout 8 seconds was dead again. any ideas?

Share this post


Link to post
Share on other sites

You could try replacing the battery,

 

but if there's an electrical problem, that would just be a waste.

 

 

 

There might might be a short or something that is causing the battery to drain power to components even when the bike's shut off.

 

or

 

There could be a solenoid that isn't clicking off when it's supposed causing it to drain power and in turn causing your battery to run hot.

Share this post


Link to post
Share on other sites

First check and clean all battery connections. Then fully charge the battery. When that's done start the bike and check the voltage reaching the battery with a multimeter. Should be at least 14 volts @ 2000 RPM. If not then it's time to verify the stator is putting out voltage. If it does the voltage regulator is bad. It's important the battery be fully charged when testing,if not the readings will be off. If the battery won't accept a full (13.2 volts) charge it's bad.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...