Jump to content
Sign in to follow this  

CRF feels like its losing power

Recommended Posts

Hi all 

after installing FMF PC4 with Powerbomb, 13T sprocket, EJK and air box mods, I was amazed with the performance.

last week I purchased a uniflow sponge filter which came pre oiled, I expected  a bit of a power boost, but disappointingly there was know difference.

the bike has been feeling like its lost the power gains it had with the mods, is it my imagination or is the bikes cpu adjusting settings and cancelling out the mods I have done.

what do u guys think.

 

https://www.youtube.com/watch?v=Sb7HzkczVP8#t=557 bike mods

Share this post


Link to post
Share on other sites

Hi all 

after installing FMF PC4 with Powerbomb, 13T sprocket, EJK and air box mods, I was amazed with the performance.

last week I purchased a uniflow sponge filter which came pre oiled, I expected  a bit of a power boost, but disappointingly there was know difference.

the bike has been feeling like its lost the power gains it had with the mods, is it my imagination or is the bikes cpu adjusting settings and cancelling out the mods I have done.

what do u guys think.

 

https://www.youtube.com/watch?v=Sb7HzkczVP8#t=557 bike mods

In my opinion oil-filters are a big NO-NO on fuel injection bikes. Oil particles get sucked in and coat your air sensors which cause issues. If I were you I would use some electrical cleaner on your sensors and go back to the dry filter or just clean the foam filter and lightly coat the outer surface with oil.

  • Like 2

Share this post


Link to post
Share on other sites

 

  1. I will b doing that today, they were very heavy handed with the oil.

 

took out filter and glad to say no oil passed through it.  

  • Like 1

Share this post


Link to post
Share on other sites

Hi all 

after installing FMF PC4 with Powerbomb, 13T sprocket, EJK and air box mods, I was amazed with the performance.

last week I purchased a uniflow sponge filter which came pre oiled, I expected  a bit of a power boost, but disappointingly there was know difference.

the bike has been feeling like its lost the power gains it had with the mods, is it my imagination or is the bikes cpu adjusting settings and cancelling out the mods I have done.

what do u guys think.

 

https://www.youtube.com/watch?v=Sb7HzkczVP8#t=557 bike mods

Did you rewind the rubberband??

  • Like 5

Share this post


Link to post
Share on other sites

I hope you're running the EJK with those mods. Couldn't load the youtube video..

yes I have EJK, still trying to find best setting for my setup, in my opinion  3-3-6 which it comes standard with is to rich for my setup. [ EJK- PC4-powerbomb-unifilter-drilled airbox] 

youtube link is working.

Share this post


Link to post
Share on other sites

Have you tried positrons settings in the EJK or ozzy adventures posting--he was spot on for the setting with the stock exhaust--I'm betting the 6 is to high?? just a guess tho!!

Share this post


Link to post
Share on other sites

Have you tried positrons settings in the EJK or ozzy adventures posting--he was spot on for the setting with the stock exhaust--I'm betting the 6 is to high?? just a guess tho!!

could u send me the links to them please.

  • Like 2

Share this post


Link to post
Share on other sites

could u send me the links to them please.

I have 300 miles on the full air box mods and Posi's settings and they work GREAT-1.5/2/3.5--is the way to go with stock exhaust--I'm going to try and get the cat out again this week!!-

The settings that are set into controller when new are 3, 3, 6, .

These need to be changed.

long time no see!!!  posi's settings are on across the board...  he did a lot for us that know not...  glad to see you enjoyed your purchase and it all worked out for the best...  

 

this one is for positron!!!    :cheers:

Gman

I was worried that I set up the EJK incorrectly

but Im good for the stage 1 is 1.5/2.5/4.5

51901394.jpg

Edited by gnath9
  • Like 7

Share this post


Link to post
Share on other sites

Thanks Bud your better at this shift than i am  :thumbsup: :thumbsup: :thumbsup:

Edited by USMCVietVet
  • Like 1

Share this post


Link to post
Share on other sites

 

could u send me the links to them please.

I have 300 miles on the full air box mods and Posi's settings and they work GREAT-1.5/2/3.5--is the way to go with stock exhaust--I'm going to try and get the cat out again this week!!-

The settings that are set into controller when new are 3, 3, 6, .

These need to be changed.

long time no see!!!  posi's settings are on across the board...  he did a lot for us that know not...  glad to see you enjoyed your purchase and it all worked out for the best...  

 

this one is for positron!!!    :cheers:

Gman

I was worried that I set up the EJK incorrectly

but Im good for the stage 1 is 1.5/2.5/4.5

51901394.jpg

 

 

wZm2T7D.gif

  • Like 5

Share this post


Link to post
Share on other sites

could u send me the links to them please.

 

 

From Posi

I assume you are currently using these settings 1.5, 2.5, 4.5, 5, 4, 4.5

You could try 1.5 2. 4. 5. 4. 4.5

After that I would try 1.5 2. 4. 5. 5.5 5.5

  • Like 4

Share this post


Link to post
Share on other sites

From Posi

I assume you are currently using these settings 1.5, 2.5, 4.5, 5, 4, 4.5

You could try 1.5 2. 4. 5. 4. 4.5

After that I would try 1.5 2. 4. 5. 5.5 5.5

is that last setting 1.5,   2,   4,   5,  5.5,   5.5       

if so, what does changing last 2 settings achieve, most people say don't change them. 

Share this post


Link to post
Share on other sites

is that last setting 1.5,   2,   4,   5,  5.5,   5.5       

if so, what does changing last 2 settings achieve, most people say don't change them.

Regarding the last 3 numbers they refer to the point at which that mode switches in. Sometimes the mode switches in too early, eg power mode switches in when you are only cruizing, increasing the value delays the switch point to the correct position.
  • Like 3

Share this post


Link to post
Share on other sites

Nevermind! Figure it out for yourself, if Posi says try it, do!  Mine runs killer and I get great mileage, but whatever!

  • Like 1

Share this post


Link to post
Share on other sites

Regarding the last 3 numbers they refer to the point at which that mode switches in. Sometimes the mode switches in too early, eg power mode switches in when you are only cruizing, increasing the value delays the switch point to the correct position.

Are u from Australia mate? I'm from Shellharbour, 1 hour south from Sydney.

will try those settings in the morning, thanks.

Edited by jorgeo65
  • Like 1

Share this post


Link to post
Share on other sites

Nevermind! Figure it out for yourself, if Posi says try it, do!  Mine runs killer and I get great mileage, but whatever!

mate, settle down, just wanted to know what the last couple of settings were.

appreciate the help, will definitely  try them tomorrow.

  • Like 2

Share this post


Link to post
Share on other sites

Are u from Australia mate? I'm from Shellharbour, 1 hour south from Sydney.

will try those settings in the morning, thanks.

Yeah I know Shellharbour. I lived at Warilla for a little while when I worked at BHP Research.
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...