Jump to content
Sign in to follow this  

2010 YZ450F no spark after rebuild

Recommended Posts

A few weeks ago I put the chain on my 2010 yz450f through the case. So I took the motor out and bought a new case, piston, rings, gasket and seals and brought it to a well know mechanic that did awesome job. I got the motor back in and put everything exactly the way it was, I've been through everything 100 times. I went through the entire ignition system,  tested the kill switch, the coil primary and secondary side, and the stator, still no spark. I'm stuck I don't know what to do. 

Share this post


Link to post
Share on other sites

Hey, have you solved your problem yet? Have you checked the flywheel? I have a similar problem at the moment. I put a new timing chain on and it wouldn't start anymore. I checked just about everything and then found out that the flywheel is damaged. ImageUploadedByThumper Talk1409211681.994641.jpg

Share this post


Link to post
Share on other sites

Yes I did. Sorry for the late reply. It ended up being something stupid. I had the kill switch plugged into the position sensor, some how. What happened to your fly wheel?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...