Jump to content
Sign in to follow this  

yz250f no spark bad fuel need help please

Recommended Posts

2004 yz250f 4stroke 

my younger brother has made a rookie error and put unleaded e10 into it the bike ran fine before as i took it for a ride before he borrowed it he filled it with e10 and went for a ride he said after about 5 mins the bike started to splutter he said he drained the fuel and replaced it with premium fuel cleaned the air filter and tryed again the bike wiuld start the splutter and die i have cleaned the carby and fuel tank lines ect but now it has no spark what could the problem be could the coil have gone or the cdi or is it a fuel thing how can i fix my bike please cheers 

Share this post


Link to post
Share on other sites

Did you also change the spark plug and check the gap ?

If the new plug has no spark, you can check the primary and secondary resistance of your coil, then compare that to specs. But also check your stator and cdi. On yamaha's website, you should be able to obtain a free copy of the electronic pdf manual for those procedures.

Edited by chittyrox

Share this post


Link to post
Share on other sites

yeah bought a new spark plug still nothing tryed the old spark plug on my crf and it sparks so its not the spark plug do you think fuel has anything to do with it

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...