Jump to content
Sign in to follow this  

Just stole a bike!

Recommended Posts

Picked this bad boy up for a whopping 375 bucks!!!

01 cr125ImageUploadedByThumper Talk1412534679.984074.jpg

Owner was about 60 and said it just wouldn't start one day, brought it home and started first kick! Kinda feel bad for the guy but if I didn't buy it someone else woulda

Ktm 520sm

  • Like 1

Share this post


Link to post
Share on other sites

Pretty sure it needs a right side crank seal, bike has no power and was dropping oil after only like 4 min of running ImageUploadedByThumper Talk1412540285.641797.jpg

Ktm 520sm

Share this post


Link to post
Share on other sites

But the good is it has v force reeds that are in great shape, full pro circut exhaust(chamber is pretty dented up)

And I nice soft aftermarket seat!

Ktm 520sm

Share this post


Link to post
Share on other sites

Seems to have good compression, piston look to be in good shape through exhaust port.

Needs crank seals

Chain and sprockets

Rear wheel bearings

Even came with a new rear tire!!

Ktm 520sm

Share this post


Link to post
Share on other sites

I have one of these turds but paid $1200 for it, nice score! That back tire also looks super fresh. Once you ditch the 36mm TMX and let the motor breathe it graduates from a turd to a really great bike. The top end keeps pulling and pulling. I also bought mine with a bad right crank seal, but after the bearing seized I rebuilt the whole motor. A few rides ago it started spooging again, but I'm long overdue to repack my silencer. They are really fun and light bikes, easy to throw around. Oh yeah, send that pipe to pacific pipe repair and it'll look like brand new for $60.

Edited by dan2581

Share this post


Link to post
Share on other sites

Well I replaced the crank seal and no more sploog! But the power on this thing just seems so flat, something must not be right. It screems but it doesn't pull like I remember my yz125 did...maybe I'm just used to the power if my ktm 520? I don't know.

Power valve is working, maybe it's not opening all the way???!? I don't have a manual but from what I understand you install the actuator arm so that when the motor is off the powervalve is sitting up against he stop pin

Ktm 520sm

Compression was at 150psi as well so top end is still in decent shape

Ktm 520sm

Share this post


Link to post
Share on other sites

Stock mikuni is jetted way too rich stock the Keihin pwk swap really helps though. The stock needle on the mikuni is the problem you have to go like two needle sizes leaner it's a must.

Share this post


Link to post
Share on other sites

Stock mikuni is jetted way too rich stock the Keihin pwk swap really helps though. The stock needle on the mikuni is the problem you have to go like two needle sizes leaner it's a must.

Well jetting is right on with pro circut specs, and I'm basally at sea level. I mean this thing is flat on power, no pull what so ever compared to my 01 yz. It was Idling pretty high when I got it I'm thinking an air leak but not sure, had to turn my idle screw out At least 3 turns to get it to idle at the right speed. I'm thinking left side crank deal

Ktm 520sm

Share this post


Link to post
Share on other sites

Glad to see progress! Have u seen the DIY leak down tester somewhere here in this forum? I think that might help u narrow it down. In fact, if u want il ship u the one i made. Hit me up if u want it.

Edit - no charge, just goodfaith u would send it back

Edited by RBI

Share this post


Link to post
Share on other sites

Not saying it won't run on stock jetting but it's boggy and flat. I went to the specs listed by dirt bike they got from honda it made the bike a lot better.

Share this post


Link to post
Share on other sites

I mean the wheel won't even come off the ground in first gear, no bogging anywhere. Jetting isn't stock but not too far off, it's pro circut specs. I think my problem goes further than jetting

Ktm 520sm

Share this post


Link to post
Share on other sites

What did you end up getting on your compression test?

150psi, enough where the bike should still run good, starts right up but the power just isn't there

Ktm 520sm

Share this post


Link to post
Share on other sites

What do the reeds look like?

They looked good, there v force 3.

Although it's been a while sense I had a 2 stroke and didn't hold it up to a light to see of they were fully sealing, I think they are good but I will double check that tonight after work

Ktm 520sm

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×