Jump to content

Sons TTR-50 problems

Recommended Posts

I'm pretty sure this has been addressed at some point but I had a hard time finding the information that I needed so I appologize if this is a repost.


With that said, I have a 2006-ttr-50 that my kids ride.  However it had been sitting in the garage for a few months when I tried to start it up again.  Of course it didnt start, not even a sound.  So checked around and found that after the last use the key was left in the on position and drained the battery.  Since the battery was a few years old already i decided to just by a new one.  After I got home and connected the battery I tried to start it... heres where it gets interesting.  The battery sounded strong (it should since it was a new battery) but all that happend was a strange winding sound coming from what I think is the relay assembly ( i think that's what it's called) kinda looks like a medel waffle on the left side of the bike just behind the battery.  Anyway bike starts up great from bump starting in third tried riding it around the neighborhood for a while hoping to jog something into place but nothing.  Not sure where to go from here.  before I just go buying parts I would like to get some help on how to troubleshoot this issue or any help that can point me in the right direction



Thank you for taking the time to read my post!!



Link to comment
Share on other sites

Sounds like a starter relay issue. It may well be from a bad connection. We can assume the battery connections are sucure. You need to check the rest of the cables. First. Disconeect teh postive wire from teh battery. A short with these large wires can be bad. The 'waffle' was the starter relay. Two large red cables. Carefully remove and reattach, ensure the are clean and not touching anything. Next, do the same thing at the stater motor. One red cable. Next trace the large black wire from the battery to the engine. (this will probably be were the trouble lay). As before, remove and reinstall. Now re-attach the large positive red wire to the battery and try the e button. If still nothing, put a meter on the red wire at the stater motor (and the other meter wire on a ground) and press the button. 12.8V (or so)? If you have volts, while holding the e button, rap on the starter motor. Anything? If you did not get the 12.8 volts, the relay is probably bad.

A service manul covers this stuff in greater depth. You might find one here:



  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

  • Create New...