Jump to content

2007 yz250 Troubles


Recommended Posts

Hey guys, just got an 07 yz250 and I'm having a little trouble getting it running right. It starts up on the first or second kick and runs great at low RPM's but as soon as I give it too much gas it starts to bog and sputter. I can ride it around as long as I don't give it too much throttle. Is it carb issues or fuel air screw? I need some help.

Link to comment
Share on other sites

The manual gives you an idea. Download it from http://arnego2.com/download/yz25.zip its from a 2008 I think.

 

Take off the pipe, you might do that first and have a look at the piston through the exhaust port. If the piston looks new don't bother to do go further if there is a reasonable amount of blow by visible go ahead and take off the head.

 

Take out the cooling fluid first, the lowest screw on the water pump housing. Lift of your tank, dismantle the rubber tube which connects the head with the radiator.

Then the PV side cover, disconnect the PV governor arm and unscrew the 4 nuts holding the cylinder. 

 

Read the manual first as you need to follow some guidelines when unhooking the PV Gov. arm.

 

Good luck.

Edited by arnego2
Link to comment
Share on other sites

Alright guys, sorry it's been a while but I finally took apart the carb and sat in a a dunk for an hour. Cleaned out all the Jets and have it back together now. I noticed the jets were screwed in all the way, is this normal? The carb had a white residue coating in the bowl so I'm hoping that was the problem keeping it from running right. I'm about to put it all back on the bike and I'll let yall know how it goes!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

×
×
  • Create New...