2002 RM250 No Top End Pull

Alright I'll describe what my bike is doing.  Starts easy as pie, idles perfect, pulls like a raped ape down low, wheelies no prob.  Then when you'd expect it to start jerking your arms off it stops pulling almost like there is a rev limiter.  Then I shift to the next gear and it starts all over. 

 

It was fouling plugs so I went down to a 45 on the pilot and a 162 on the main jets from a 47 pilot and a 168 main.  No change.  Powervalve is brand new and works fine, timing is spot on.  Less than 2 hours on a new top end.

 

I ride enduro and elevation is anywhere between 0-300 above sea and I'm in Houston so lots of heat and humidity.  All I can figure is it is either a bad CDI or jetting issue.  Running 40:1 with Klotz and premium fuel.  Stock pipe and silencer so I already feel like my bike is jetted on the lean side and it still acts like it is a bit rich.

 

Thanks guys!

 

 

My 01 was doing same thing when I moved from Wisconsin to Utah. It was the jetting. Also clip position on needle.

Power valve adjusted correctly?

Power valve is good and so are the reeds. Cleaning the carb today

My friend had a 02 rm125 that was exactly like that it had loads of power and once it hit the powerband it just flattened right out

What's the preload on the power valve spring set at? What's yours compression, when's the last time you checked the power valve to see if it operates smoothly? Is the tps working? There's a lot of tedious work with issues like this

problem solved.  i installed a new stator and flywheel weight and now she rips like she is supposed to.  Best I can figure is I was getting a weak spark from the old stator which did look oily and worn.

problem solved. i installed a new stator and flywheel weight and now she rips like she is supposed to. Best I can figure is I was getting a weak spark from the old stator which did look oily and worn.

did you use the same stock stator and flywheel weight? if not which weight did you use?

did you use the same stock stator and flywheel weight? if not which weight did you use?

Got a rickey stator stator and added a 13 oz steahly fww

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now