Need help from someone with good engine knowledge

I have a yz400f but am posting this here bc I want to know if anyone has had this happen to them even if they dont have a yamaha or no what my problem is.   The problem is my bike will foul the spark plug in a few minutes.  Its valves are all in spec, new piston and rings, new water pump shaft, and whole motor was just went through.  It will start up fine but has a little hesitation when you accelerate and then the spark plug fouls. Could the problem be a bad coil, spark plug cap or wire or what?  Any helpful advice is appreciated!

also when you rev it hard it will shoot out a black smoke sometimes but not always

Clean your air filter to start with.  That may explain the smoke. 

 

 

It will start up fine but has a little hesitation when you accelerate and then the spark plug fouls.

 

Explain what happens, and why you think the plug is fouling.  Does the bike quit running?  What is the brand and heat range number of the spark plug?

Like it will run rough in lower rpms and want to bog down but runs good in higher rpms. Also sometimes if i pull in the clutch it stalls but starts up fine. It will shut off even if im in the higher rpms to not just lower rpms.  I think its something electical and not jetting but dont know

Edited by Adam842

Clean your air filter to start with.  That may explain the smoke. 

 

 

Explain what happens, and why you think the plug is fouling.  Does the bike quit running?  What is the brand and heat range number of the spark plug?

Ill have to check on the spark plug

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now