2014 yz450f pops on deceleration-any thoughts

use only renegade 110/93(no eth) for practice and sx4 for racing. At lorettas fmf changed the header pipe. Did not pop last moto,but sat for a week off and now pops on decel. Should I start back at factory setting ? Barr's stage 1 mods,only.

It sounds like your fuel/air screw is too lean, see where it is set at but it should be set 2-2.5 turns out from close

I have a 2009 kx250f and it used to pop a ton but not always when decelerating and i found my fuel/air screw was waaayy to lean i have the finger adjust on it so i just turned it in all the way to find where its close is then turned it out 21/8 turns and now it doesnt pop what so ever

...accept he's FI.

 

 

 

 

 

Dam, I don't know why I always miss that. Guess I'm just behind the times.

When you say TPS mount are you referring to the throttle positioning sensor? Or something different

When you say TPS mount are you referring to the throttle positioning sensor? Or something different

 

Yes.

It can leak air into the TB.

 

If you have never cleaned and dielectric greased your electrical connections, do that first.

Okay good to know

Would that possibly cause a no idle/hard start?

Okay good to know

Would that possibly cause a no idle/hard start?

 

Yes.

 

Have you checked you high-idle / idle knob to see it it's pulled out ?

Idle knob? If you are meaning the choke it doesnt make a difference whether cold or hot on starting or idle it has just progressively becoming worse, i have the air/fuel 2 turns out and the idle screw is 2 turns out but i have been adjusting it but no change, i dont know what the issue is anymore possibly just need to pick up a carb rebuild kit it has no air leaks nothing. I have gone over the bike for clearances, timing, cant do a leak down test because i dont have one but when i push start it it fires at 1/4 throttle right away and runs great until you stop it will die instantly

I am mechanically inclined but this thing has been stumping me lol ive checked everything there is to check and maintain which is why it boggles me that it doesnt run unless i am over thinking the process and missing the more delicate issues but even then all the drain tubes and fuel line are clean and they way they should be

But i did not clean or dialectric grease the tps but oddly enough it was unplugged and ran fine but when i went to pull the carb off i plugged it in and it didnt change

As it progressed (3 rides of roughly 2 hours each) it became worse it would take a few kicks to start then would take 10 minutes of kicking and would only idle with choke on now it wont start by kicking and will not idle with choke or no choke and will only run 1/4 throttle or more from push starting

I have a 2009 kx250f and it used to pop a ton but not always when decelerating and i found my fuel/air screw was waaayy to lean i have the finger adjust on it so i just turned it in all the way to find where its close is then turned it out 21/8 turns and now it doesnt pop what so ever

 

Stop cross posting!

 

Start your own thread....

Idle knob? If you are meaning the choke it doesnt make a difference whether cold or hot on starting or idle it has just progressively becoming worse, i have the air/fuel 2 turns out and the idle screw is 2 turns out but i have been adjusting it but no change, i dont know what the issue is anymore possibly just need to pick up a carb rebuild kit it has no air leaks nothing. I have gone over the bike for clearances, timing, cant do a leak down test because i dont have one but when i push start it it fires at 1/4 throttle right away and runs great until you stop it will die instantly

 

STOP  cross posting.

 

This is not a chat room

Hello, I'm new at this but I'm in desperate need! If anyone could help me out or point me to where I need to go to ask I'd appreciate it. - I have a 2006 AND a 2008 yz450 f I am a racer at necxc and GNCC and after a race or my last lap both will jump time every time. I have done all I can do and I still don't know why it's jumping time.

Well on the 2014 yz450f it is fuel injected. For me I added fuel with my GYTR tuner on the bottom of the throttle position. That helped a lot!!! Hope I didn't miss something you posted, but I would try the tuner.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now