Jump to content
Sign in to follow this  

Bike won't run without a battery

Recommended Posts

Hey guys I recently bought an 02 drz 400e. I didn't go over everything before I went riding and about 45 minutes in the battery housing fell off as well as the battery. When this happened the battery connectors ripped off.

I decided to start the bike throw the battery in my backpack and continue to ride. About 20 minutes later we stopped at a lake and I couldn't get the bike running.

When trying to start the bike by the lake I accidentally put the positive wire on the negative post and vise versa could this have shorted out a stator or regulator? The bike will start when correctly hooked up to a battery but does the second you take the battery away? Please help I'm not to this

Share this post


Link to post
Share on other sites

Very possibly could have damaged the regulator/rectifier (RR) with the reversed connection.  The fact that it runs with a battery is good.  Probably did not damage the stator.

 

I would start by doing all of the electrical tests in FAQ and report the results.  That will tell you if the stator is good, possibly confirm the RR is good or bad (often hard to tell) and if any charge is going to the battery.  As you originally found out, it will run without the battery but is not very happy doing so.

Share this post


Link to post
Share on other sites

Still can't find a fuse. Checked RR it seems OK. Only has a .012 difference when checked in reverse. Tested the battery wen running was at 12.3. Where do I go from here

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...