Jump to content
Sign in to follow this  

91 yz-125 compression test, no start.

Recommended Posts

Hello all

 I'm new to this forum and to 2 strokes.  I bought a basket case 1991 yz-125. Looks like lots of aftermarket parts and mucking about. I replaced the stator and rewired the bike, I have a strong spark and the carb is clean, reeds are boyseen with no outter plates. The bike just will not start, kick or roll. I did a compression test and got 120 psi after 5 kicks. Do I need to do the piston and ring? I have lots of mechanic experience with 4x4s and cars. Help me defeat my gremlin.

Thnaks

Share this post


Link to post
Share on other sites

Remove the spark plug add a few drops of gas in the cylinder put spark plug back and then kick,,,

try some carb cleaner directly inside carb, remove the filter even though you say the carb is clean and try kick starting again,,,

If no response still next remove top end and make sure piston ring is lined up and the arrow pointing forward, then align the piston at top center, tighten everything back up and try kick starting again

Share this post


Link to post
Share on other sites

Ok. Christmas has come and gone and this dang bike still won't run. I have good spark,the stator is new and wiring checks out, plus I can see the spark when testing. I rebuilt the top end with a new piston and gaskets, compression is now 155b/ft. Could the whole problem be the carb? Timing? 

Share this post


Link to post
Share on other sites

I'll double check the timing nd can run a test on the coil but considering I have spark it shouldn't be the coil. Gonna pull the carb apart, maybe it's something simple like a bad float.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...