Jump to content
Sign in to follow this  

Please Help. What did I do wrong?

Recommended Posts

The other day I was having hard starting issues with my 94 rm250, but when I could get it to start it ran great. So I pulled off the carb and cleaned it well and pulled out the reeds and inspected them (need new reeds soon)...I put everything back together and now the bike goes to about 1/2 throttle then it's like a rev limiter... The only way it will hit powerband is if it's in 4th or 5th gear.... I already check the PV and it appears to be working properly.... Can someone please tell me what I did wrong?

Share this post


Link to post
Share on other sites

check the jet needle and throttle slide valve basically check everything from the throttle cable to the needle

Share this post


Link to post
Share on other sites

The other day I was having hard starting issues with my 94 rm250, but when I could get it to start it ran great. So I pulled off the carb and cleaned it well and pulled out the reeds and inspected them (need new reeds soon)...I put everything back together and now the bike goes to about 1/2 throttle then it's like a rev limiter... The only way it will hit powerband is if it's in 4th or 5th gear.... I already check the PV and it appears to be working properly.... Can someone please tell me what I did wrong?

i'm thinking you put the seat on wrong.....but no seriously.....id go after the carb and clean it out completely....good luck !!   oh and maybe check those reeds....replace them !!   is there water in your gas? is the cdi unit shorting out from a worn out spot hitting the frame somewhere? and the float, thats a good place to check if there is water or a stuck float....again good luck, and i was serious about putting your seat on wrong and binding some wires up....  oh and id check if the reed stops are put on properly.... it sounds like a fuel delivery problem too so are the overflow tubes clear on the carb and motor....good luck my friend

Edited by joethumper

Share this post


Link to post
Share on other sites

just curious when was the last time any motor work was done to the bike?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...