Jump to content
Sign in to follow this  

2012 kx250f no start! Help!

Recommended Posts

Hey, so we rebuilt the motor on my 2012 kx250f after it blew up. New cams, cam chain , valves,valve seats and buckets,piston, cylinder ,crank,crank bearings. Replaced everything besides the transmission basically. Got the bike all back together , fired up after a few kicks and rode it for about 15 mins just breaking everything in. Parked it and went to the track the next day started second kick and then died about 10 seconds after. It hasn't started since. No error codes come up compression is spot on as well as the timing. Been to 3 different shops and nobody can figure it out. Any ideas??

Share this post


Link to post
Share on other sites

Have you checked the basics like cam timing, all the electrical connectors, is there spark, is the fuel pump working ?  

Share this post


Link to post
Share on other sites

Yeah timing is spot on been checked about 10 times. The fuel pump seems to be working when I connected power to it. I thought the electrical connectors were the issue so we ended up getting a new wire harness for it and still nothing. It is also getting good spark to.

Share this post


Link to post
Share on other sites

If spark is good and timing is good, must be fuel, right? Since you have two fuel injectors, would it run if one were plugged? Can you shoot a little starter fluid in there to see if it fires? Then you can rev it up to where the second fuel injector would kick in. Recheck pump. Maybe clogged fuel pump filter (integral to pump). 

Edited by LSHD

Share this post


Link to post
Share on other sites

Sorry forgot my password for this account lol. Tested every sensor on the bike and they are all within spec. Fuel pump is pumping and both the injectors were cleaned and have a good spray. It has spark but I took off the ignition cover and found a little knick on the stator. I was thinking maybe it's getting spark but just not enough to actually get the bike to fire. Maybe the spark is arking there a little. The bike won't fire up even with the starter fluid

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...