Jump to content
Sign in to follow this  

Clutch dragging

Recommended Posts

Just rebuilt sons Kx 85 and now noticing quite a bit of clutch "drag". Adjusted perch screw all the way in to get very little clutch engage. Wondering if i should buy new clutch kit or any ideas I can try.

Share this post


Link to post
Share on other sites

Huh. That's weird. Is it like not disengaging? Or its just in limbo? Kind of sounds like the cable could be messed up but if you just rebuilt the motor you would have seen it. I don't know man. But good luck getting a solution!

Share this post


Link to post
Share on other sites

Has it sat for awhile?  Clutch plates can get sticky from sitting, but should free up once it's warm and had a little ride.  If not that I'd look at the cable, when a clutch wears out it will normally slip more and fail to fully engage. 

Share this post


Link to post
Share on other sites

KX85 has an adjustment behind the front number plate also. Check that. You can easily adjust a KX85 by looking down at the lever that the clutch cable hooks onto. Adjust it until the lever stops moving back and then tighten a little bit. Just enough so the clutch lever has a little bit of free play.

Share this post


Link to post
Share on other sites

It did sit for a week or so got them good and wet with oil then installed did notice one of the friction plates was broke when I put it in, could that be my problem?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...