Jump to content
Sign in to follow this  

Yz 125 leaking black oil

Recommended Posts

My 2009 yz125 is covered in this black oil on the right side of the engine that comes from the powervalve. https://gyazo.com/c5bb53e2e49c2b65fbbd3e09527eb1ffin this picture it leaks from part #33. Its done that ever since i replaced it and it leaks the oil and makes the engine look bad. Anyone have any ideas on how to fix it?

Share this post


Link to post
Share on other sites

It's unburnt fuel. Take it apart, clean the whole PV system and cylinder. Reassemble then dial in your jetting. Should take care of it.

Share this post


Link to post
Share on other sites

It's unburnt fuel. Take it apart, clean the whole PV system and cylinder. Reassemble then dial in your jetting. Should take care of it.

Ive never jetted a carb before, You know how i can started on learning how to properly set up the carburetor? It also leaks when the bike isnt even running

Edited by J0nathan27

Share this post


Link to post
Share on other sites

Look in the FAQ at the top of this page. There's 2 pages on jetting. Definitely take the time to learn jetting. It will uncork free power you don't realize your missing.

Share this post


Link to post
Share on other sites

From your other thread your bike has a 144 bore and not a 125.

 

A big bore requires leaner carburator settings than a stock bore 125,

reason your bike now runs rich and spooges excessive oil out the YPVS area.

 

Re-jet your bike properly and on top of stopping the spooge your engine will run much crisper/stronger.

 

Have a look at this recent thread : http://www.thumpertalk.com/topic/1160390-yz144-jetting-questions/

Edited by mlatour

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...