Jump to content
Sign in to follow this  

crm 250 frankenbike not running right.

Recommended Posts

hey guys. my 89 crm was running well when i got it. . . however now im having a few problems. the bike starts first kick and idles perfectly but when opening her up she stuters badly and wont clear or hit the poweband. when i changed the plug it ran well but a week later same problem. so far i have cleaned and set the carb , replaced plug, fresh gas and oil, cleaned the pipe and replaced spark plug cap and lead. not sure where else to look. any help is much appreciated.

Share this post


Link to post
Share on other sites

On my 89,and 85 cr-250's I replaced the float-valve needles, those things can become worn with age, your Honda dealer should be able to order you some, they are a little bit pricy, My 2 cr's ran a-lot better after that, now you might want to look your Honda power port valves, they could be sticking, from carbon fouling, get a shop manual, because it can be an involved task re-setting em after cleaning em, you can do it!  243961.png

Share this post


Link to post
Share on other sites

Crm250 check your voltage regulator the old honda ones with out the heat sink wear out. I had one go out on my nsr250 it was running great then instantly ran like crap. It would start and not Rev clean pop sputtered eventually it wouldn't start.

It had me chasing the plug thinking it was jetting or the stator. Nope just a $50 voltage regulator aka rectifier. It's a common problem with all honda street bikes from the 80's to mid 90's.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...