Jump to content
Sign in to follow this  

Bad rim?

Recommended Posts

Recently bought an 05 yz125. The first week I had it the rear tire kept losing air and the bead would fall inside the rim. I went and put a new tire on it thinking that it would fix the problem. Well after 3 hours of riding today I get the bike home and see the same thing. This tire is also losing air but I didnt think anything of it before now. The rim "looks" straight by the naked eye but I think it might be bent. Anyone else run into something like this? It is the stock rim on the bike. Maybe I should think about upgrading to aftermarket rims and hubs.

Share this post


Link to post
Share on other sites

I would change the inner tube and rimlock sounds like the rimlock got tore up and popped the inner tube. Happened to me a few times.

Edited by Matt Gunter
  • Like 1

Share this post


Link to post
Share on other sites

It's the inner tube that holds the air, not the tire or rim.  (unlike a tubeless tire on a car)

 

You could run a bald tire mounted on a bent rim and it wouldn't matter as long as the inner tube held it's pressure.

 

A new inner tube, a new rim strip (or 1-2 layers of duct tape will also work)

and inspect inside the rim/rimlock if anything sharp is rubbing on the innertube.

Edited by mlatour

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...