Jump to content
Sign in to follow this  

Launch Control Light Question

Recommended Posts

Just bought a new 2015, 11.5 hours on it and never has the orange launch control light come on. Laid it over in the desert lightly and now the launch control light comes on for a second or two upon kicking it over and then goes off. Tow buddies who have 2014's said theirs always did this, mind never did until one minor drop to the side. 

 

This would not appear to be normal as others have posted since it did not do that from the day I put the first hour on it.

 

Anyone have any experience with this so far?

 

 

Share this post


Link to post
Share on other sites

What happens when you try to use the launch control, ie. press and hold the button? Does your light work then? Do you notice any difference when launching? 

 

The light should come on when you kick the bike over. It stops flashing when the bike is running and launch control has not been activated. When you activate the launch control (either 1st or 2nd gear) the light should blink right up until you shift into 3rd (if I remember correctly) Try follow the wiring and see if there are any loose connections. 

Share this post


Link to post
Share on other sites

I have not attempted to use the Launch Control for its intended purpose yet. You state the light should come on upon kicking over which it does... now... but did not prior to laying it over? That is the point of my confusion, I have read this, and people I know say theirs does, but mine did not from brand new up till this point?

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...