Jump to content
Sign in to follow this  

I think I am loosing coolant, have smell from right top side of motor.

Recommended Posts

Hi,

 

I think I am loosing coolant, can't see anything below the WP, radiators are dry, filled the overflow to keep an eye it (was very low when cold) and now back to a low level.

 

Started looking around after it was running, I can smell coolant from the right side by the top of hte head, no viable leaking or stains.

 

Oil looks clean and is not milky when I check, coolant is nice and green.

 

Gonna change the oil and make sure is all good, what/where should I start for the leak/smell (RTV mod or too late?) 

Share this post


Link to post
Share on other sites

Isn't the overflow bottle just supposed to be for overflow, not a reservoir? As in not supposed to be much in it. If it's full it's gonna blow out, as far as I know.

Share this post


Link to post
Share on other sites

Hi,

I think I am loosing coolant, can't see anything below the WP, radiators are dry, filled the overflow to keep an eye it (was very low when cold) and now back to a low level.

Started looking around after it was running, I can smell coolant from the right side by the top of hte head, no viable leaking or stains.

Oil looks clean and is not milky when I check, coolant is nice and green.

Gonna change the oil and make sure is all good, what/where should I start for the leak/smell (RTV mod or too late?)

dump the overflow bottle, fill the radiators, burp the system, and ride.

the overflow container is for expansion, not filling

Share this post


Link to post
Share on other sites

I guess I should be clear, I do not use the Overflow for filling just to keep an eye on the level (as posted here in Thumpertalk as a good thing to do).

 

The radiator is full, mainly looking for help with the clear smell I am getting from the top of the head it seems. I can't find anything about this when I searched about this being common..

Share this post


Link to post
Share on other sites

ride in rain recently?

 

everytime I ride to wrok in rain, it smells  the next time I use it....all the road debris just bake on the exhaust/engine and the smell could feel like coolant sometimes...but it's not.

Share this post


Link to post
Share on other sites

I guess I should be clear, I do not use the Overflow for filling just to keep an eye on the level (as posted here in Thumpertalk as a good thing to do).

The radiator is full, mainly looking for help with the clear smell I am getting from the top of the head it seems. I can't find anything about this when I searched about this being common..

do as stated above, you want to insure there isn't air in the system causing pressure to climb. then check again after a long ride

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...