Jump to content
Sign in to follow this  

Need help diagnosing dual sport kit

Recommended Posts

Hey TT, this is my first time posting so I apologize if this goes in the wrong section. I need some help diagnosing an issue with my dual sport kit. I just bought a 2002 wr250f off of craigslist. Its in good shape, only needed minor maintenance type things, and came with a street legal title and an old Electrex Dakar kit on it. ( I believe they stopped making it? Cant seem to find any information online about it...) The seller had told me the battery was bad so it wouldn't work, I took his word on it and bought a new battery with the bike. It wound up working after I re-soldered a very loose fuse holder to the pcb.

 

Now another problem has come up - Like I said, everything was working perfectly after the battery install, and then it sat for 2 days in my garage, untouched. Next time I rolled it out and turned the key, no lights came on. I tried the blinkers - nothing. Horn - nothing. I started it and the lights came on as expected (They can run on their own with the stator, no battery) and I tried the blinkers again. This time, they blinked very slowly, like they weren't getting enough juice. I figured that the battery's power somehow wasn't getting to the rest of the components, and the whole kit was trying to work on just the stator output. I tore the whole kit down again, checked connections and everything seemed fine. I hooked the kit up off of the bike and still the lights would not work on battery power. 

 

Share this post


Link to post
Share on other sites

a little something on the Dakar kit.  did you turn the key off?

 

I have the Dakar on my XR400R and if I dont turn the key off it kills the battery.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...