Jump to content
Sign in to follow this  

yz250F oil level ?

Recommended Posts

Just completed the rebuild, bottom and top end on 2002 YZ 250 F. Added one quart of oil, ran bike and checked oil. Didn't show on the dip stick. I'm up to 2 1/2 quarts, still not showing on the dip stick. Any advise.

thanks

Share this post


Link to post
Share on other sites

Ahhhh, something is wrong, like the oil pump is not pumping.

Did you check the oil pump when you did the rebuild, and bleed bolt on the head when it was running to see if oil is coming out?

If not, stop, tear out the right side cover and remove the oil pump and check condition RIGHT NOW before you destroy all the work you just did.

 

1.25 quarts should have it on the stick.

Edited by ronbuell

Share this post


Link to post
Share on other sites

Partial thread jack here, when doing a rebuild, does one need to bleed the oil system somehow? Or should oil distribute itself accordingly on its own?

Share this post


Link to post
Share on other sites

Partial thread jack here, when doing a rebuild, does one need to bleed the oil system somehow? Or should oil distribute itself accordingly on its own?

You don't have to bleed it, but there is a pressure check bolt on the side of the head that you loosen while its idling and see if pressure is getting to the head.

Edited by ronbuell
  • Like 1

Share this post


Link to post
Share on other sites

I think it only goes in 1 way since there is a boss that sticks out on the cover.

I only say it cause my friend had a trr230 airfilter In the wrong way and it didn't allow oil to pass through

Share this post


Link to post
Share on other sites

ahh, I think I had the same problem on my 02 yz250f, the oil is just really hard to see on the dipstick, be sure to wipe the dipstick really well before putting it back in to check the level

Share this post


Link to post
Share on other sites

Thanks to all for hints and suggestions. I did check to see that it was getting oil at the oil screw on the head, it was. It wasn't getting hot, no oil in the coolant no coolant in the oil.

I'm going to open it up and replace the oil rings down in the oil pump region. i'll let you all know how it comes out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...