Jump to content
Sign in to follow this  

help 300xc

Recommended Posts

I decided to put all new plastics on my 2014 KTM 300xc. After reassembling the rear section( subframe,airbox, air filter, elecronics), I installed an antigravity lithium battery from rocky mountain atv/mc.. when I hit the start button smoke came from the coil, or electric box right in center above the air filter.. No visible signs of a smashed wire grounding out or anything like that... only new thing electronically is the battery.. the bike will spin over but will not start, i tried disconnecting the battery and kicking it, still nothing.. Any suggestions are appreciated..Has anyone else exprienced this?

Share this post


Link to post
Share on other sites

Is the 4 prong block shaped plug plugged back into the battery housing? I know I forgot to plug that back in once and fried a battery. I dont know exactly what that is and what fundamentally occurred to the battery, but it definitely did a lot of harm.

Share this post


Link to post
Share on other sites

Doubt it is the relay if it wont start with the kickstarter, relay should only control the e starter. First make sure you have the polarity right on the battery leads. Then remove the plug and kick it over and see if there is spark, if no spark, start testing coils and reg/rectifier

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...