Jump to content
Sign in to follow this  

2007 YZ 450f stalling

Recommended Posts

New to me Yz 450f (two stroke up till now). Bike is stalling when you crack the throttle open. In difficult terrain (i ride very technical trails) this is a problem as I end up on the ground trying to get over a log or obstacles. Just had the carb acid cleaned (green inside) and the valves done (they were still in tolerance but they put them right where they should be). Bike runs great as long as you don't twist the throttle hard at a low rpm. Twist it moderately hard and it has a pretty good hesitation. Roll it on and it revs great. Not sure if changing the clip height will help this. Also looking in to a recluse clutch but not sure if that will prevent the stalling. Any ideas would be greatly appreciated. I've done all the work on all my 2 stokes so I have mechanical knowledge just not sure about the 4 stroke thing. Wondering about the main jet and also considered heavier flywheel. Wish I would have bought a more trail rideable bike but this was in excellent condition except for leftover gas. Bike is like new and I got it for $1200.00

Share this post


Link to post
Share on other sites

You cannot dip the carb in caustic cleaners, you will damage internal seals

Not accepting throttle is a sign the AP needs servicing. Leave the rest of the jetting alone.

You should make whoever 'serviced' the carb to finish the job.

Share this post


Link to post
Share on other sites

Sadly it was one of the best race mechanic shops around here. He said it was so filled with gummed out green gas that he had to use acid to clean it to even get it to move. Completely cleaned and redone according to him. He said it should be better and it is but it still stalls on throttle cracks to wide open. The bike is new to me so I have never serviced it or it would never have been in that condition. My Cr250r 1991 looks like brand new and runs like new because of my constant maintenance so I guess I will have to tear this bike down and begin with it. It runs great as long as you don't hit the throttle hard from a very low rpm. Other than that it runs great. 

Share this post


Link to post
Share on other sites

If the bike runs fine accept for the qucik WOT issue, it is NOT jetting, it is the apump, as mentioned.

It is probaby still corroded and not working.

Pull up the subframe and verify the squirt

 

There are hunderds of posts on this subject 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...