Jump to content
Sign in to follow this  

04 YZ250F Decompression Cable

Recommended Posts

I recently purchased an 04 Yz250f. The decompression lever cable was not attached but provided with the purchase. I have tried routing it but when attached it is too long to pull the lever when engaged by able 2 inches. The cable I have is 38 inches long. I feel like there is something missing on the bottom end because there is nothing to hold the cable sleeve in place when depressed. Does anyone have pics of the correct routing, attachment or the cable length needed? I jave searched but did not find anything relevant to my issue

Share this post


Link to post
Share on other sites

I don't believe an 04 had decompression cable at all. Those were only in the 01 & 02 models. Us 01 owners would buy an 03 exhaust cam, eliminating the whole cable set up. Mine sits on a shelf for anyone ever in the need for one. There is a service manual somewhere on this forum, if you need one pm me your address. I think you have an older bike than what the seller told you if you need a cable.

Share this post


Link to post
Share on other sites

I checked the vin and the 10th digit is a 4. I can attach a picture when i get off work tonight. It definitely has a valve on the front just behind the radiator. When i press it up by hand the motor looses all compression

Share this post


Link to post
Share on other sites

Now I'm really confused. I thought something was a bit off when i didnt have the red hot start knob on the carb. I know people switch the older cams to the newer 03 and 04s. Is there any reason someone would do the opposite? Or maybe the motor was swapped by a previous owner? Is there a date code anywhere on the engine. That worries me if I need any internal parts that changed over those few years.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...