Jump to content
Sign in to follow this  

OIL leak @ the water pump cover.

Recommended Posts

Anyone have this issue? it looks like i have a leak at the water pump cover. Just a quick glance but ill need to tear it down a little bit to see exactly where. Is this a common place to leak?

Share this post


Link to post
Share on other sites

Anyone have this issue? it looks like i have a leak at the water pump cover. Just a quick glance but ill need to tear it down a little bit to see exactly where. Is this a common place to leak?

 

What bike model and year?

 

But to answer your question, no , it hasn't been an issue for me yet on my 2014 498RR.

Share this post


Link to post
Share on other sites

Anyone have this issue? it looks like i have a leak at the water pump cover. Just a quick glance but ill need to tear it down a little bit to see exactly where. Is this a common place to leak?

On two strokes it's not unheard of. Take the pipe off and snug the side cover screws up, clean the surfaces, replace the pipe and see if it reoccurs.

Share this post


Link to post
Share on other sites

Thanks for the replies. Bike is a 2015 Beta 300 XTrainer, (same as in the signature)  Sorry i didn't specify.

Share this post


Link to post
Share on other sites

I had a leak on mine.  Took the PV cover off, added a thin bead of black (oil resistant) RTV to the gasket and torqued to spec.  Not a drop since.  

  • Like 1

Share this post


Link to post
Share on other sites

If its at the water pump housing then look on the bottom. There is weeping hole on the bottom. That's there to piss water when your seals go bad. If that's the case to pull the rotor and the side case off replace the two seals and the one bearing put it all back together add a new fluids and you're done. Pretty common deal.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...