Jump to content
Sign in to follow this  

YZ 85 CLUTCH PROBLEM? HELP

Recommended Posts

i bought the bike cheap last week and was told nothing was up with it apart from a missing clutch cable. The bike rattles a little and there is not smooth power in the bike at all especially in lower gears wont hit the powerband at all. When i have looked at it properly, the clutch actuator appears to be broken, it is loose and wont spring back into position like i imagine it should.

I think clutch plates may need replacing but why is the actuator broken?? 

the actuator is on the left side of the bike whereas the clutch plates are on the right side i think

the bike does have lots of compression, starts first time everytime and does ride in all gears so i doubt its an engine problem or gear problem

What do you think the problem is and how much would it cost to get fixed 

 

 

first time posting any help would be much appreciated 

 

Thankyouu

Share this post


Link to post
Share on other sites

Where does the rattling sound appear to come from ?

 

Not hitting powerband could be many many things,

from a slipping clutch, a fouled spark plug, a mis-adjusted carburator all the way to a worn-out engine.

 

Search online for a Service Manual specific to your model/year,

buy or download it as it will be very valuable in fixing your bike.

 

You'll have to dis-assemble to find what's missing or broken in the clutch actuator :

 

CLUTCH.png

Edited by mlatour

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...