Jump to content
Sign in to follow this  

2003 XR80 HELP

Recommended Posts

I recently picked up a 2003 xr80 for a good price from a friend. His dad was hassling him about the bike taking up room in the garage and since he didn't ride it any more I thought it would be a good bike to get. When I got the bike there was no gas in it. It sat for close to two years, I got the bike Cleaned the entire carb jet pilot and all, changed oil, put new plug in it, new air filter, put a spark arrestor on,p. When I start the bike it idles but will cut off. Even if your riding it will cut off, but you won't get far if you try riding. I'm kind of stuck with wha to do, can't think of what it could be. New lines?ImageUploadedByThumper Talk1453339676.066931.jpg

Share this post


Link to post
Share on other sites

Yeah but if he rigged it somehow, it could be fault, either that or check your ignition coil, it could not be giving enough of a spark

Share this post


Link to post
Share on other sites

Yeah but if he rigged it somehow, it could be fault, either that or check your ignition coil, it could not be giving enough of a spark

 

Clean grounds and connectors for sure. The spark plug cap winds onto the wire. you can remove the cap from the wire and trip just a 1/4" of and then reinstall. They can get a bit of corrosion in there.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...