Jump to content
Sign in to follow this  

new member xr650r help needed

Recommended Posts

Hi all, new member here, dont now how i introduce myself its rubbish on my phone!! but will get to that

i have searched all over for help but nothing seems to work so i hope i can get some help here

my bike: 2001 honda xr650r

lots of modifications

falicon rod

high comp piston

port & polish

valve seat work

stage 1 hotcam

full akro

side pannel induction kit

Brisk plug

my carb is std with: 68s and 180 main b53e needle 3rd clip

IT JUST WONT RUN RIGHT!!!!!

the idle goes up and down and cuts out when it wants, now and then it will run spot on till its warm then it idles high, i blip the throttle to bring it down and it cuts out, my mixture screw does nothing!! in the bike runs and out it still runs, i have removed the choke plate flap, blocked the AJCV and this seemed to cure my hanging idle, i tried a 65 pilot and no good, the bike (after plugging ajcv and choke flap removal) now idles nice when it wants to but still hangs a bit but not to bad, it revs good but STILL!!! it cuts out when the idle drops, once warm its worse!! i cant fix this!! can someone please help?

OR.........would you reccomend a pumper carb? i can get a tm40 if thats any better?

HUGE thanks for any help

Share this post


Link to post
Share on other sites

Greetings I think its your carb some one correct me if I'm wrong but everything you describe is carb related or controlled by your carb if i was you and had to mess with jetting i would grab up that pumper carb you have to do jetting any way i could be wrong but good luck

Share this post


Link to post
Share on other sites

Yes thanks, no matter what i try the bike just wont run good, think i will just get a pumper

Share this post


Link to post
Share on other sites

May have found a problem but not building my hopes up with this carb

my mixture screw ive just taken out to clean the carb again, ive found 2 washers, a good o ring and a o ring under that in tiny pieces!! po must have been non mechanical or something

Share this post


Link to post
Share on other sites

That will definitely do funny things. When I had the OEM carb that o-ring/washer wash reversed (PO had a dynojet kit in it and the o-ring was toast). Easy fix and the problem got me an XR for very cheap. I ended up going to a TM-40. I had no problems with my stock carb, except the inherit lackluster throttle response of that style carb. When a brand new tm40 kit showed up on the advrider flea market popped up for $300 with extended throttle cables...I couldn't resist. It's, hands down a better carb. As you will/have read, it takes a bit to get it set up right, but I had no trouble at all really. Mine runs smooth as silk today and it's the third best mod for that bike (uncork and suspension being 1&2).

  • Like 1

Share this post


Link to post
Share on other sites

I think i have done it!! ive stripped the carb and flushed out all the pilot jet circuit and removed the tiny pieces of ruined "o" ring, cleaned and blasted the circuit and reinstalled a newish o ring washer and spring, the bike now cuts out when i screw the mix screw all way in and it neva done that before, BUT it doesent stumble when i screw it out, it just stays the same, ive set it to 2 1/2 turns and it seems to be running alot better

Share this post


Link to post
Share on other sites

If the idle doesnt drop when you back it all the way out, you need to go up a size on your pilot.

Share this post


Link to post
Share on other sites

Yes thats what ive just read, will try it and see how it goes

huge relief now ive got it running better and found the problem

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...