Jump to content
Sign in to follow this  

05 kx 85 bogs and dies

Recommended Posts

Ok my nephews bike died in a race. Got it back to truck i started it fine. Idles good. But when snap throttle to wide open it bogs and dies.if you roll easy on throttle to prob 1/4 throttle then snap to wide open it revs out fine Does when riding too.

Bike history. 10-12 hrs on top and bottom end rebuild. Ive replaced stator and coil. Fresh gas. Reeds seem fine. Checked for air leaks with carb cleaner. Cleaned carb 10 times. All vents work. Float is ser correctly

Edited by tom ward

Share this post


Link to post
Share on other sites

I dont think its jetting. Been same since i bought it a yr ago.140main. 45 pilot. Needle 3rd from top.doesnt change the running if you change clip position also has 155 psi compression.

Share this post


Link to post
Share on other sites

Is it the first time you've ran it in the cold weather? It'll run leaner the colder it is. Have u tried adjusting the air screw? It maybe off in this cold air. Did u check the float hight?

Share this post


Link to post
Share on other sites

Just seen you checked float hight. I've got an 04 it's pretty finicky with the air screw adjustment with temperature changes.

Share this post


Link to post
Share on other sites

Ive played with the air screw doesn't seem to help any. Ive changed clip positions and i went from a 45 to a 50 pilot still nothin. Rode it last year in cold weather with same jetting and no problems. Guess gonns do a leakdown test

Share this post


Link to post
Share on other sites

No it would sputter and crackle if it was too rich. Probably foul the plug. A bog is a result of too much air and not enough fuel (lean). Yeah I'd do the leak down test too.

Share this post


Link to post
Share on other sites

Leakdown test checked out good. Put it back together. Stock jettin with air screw only 1/2 turn out it revs good from an idle and revs great while riding. Put the next step richer pilot in and set ir screw and cant get it to rev

Share this post


Link to post
Share on other sites

With the richer pilot. It sputters like its to rich no matter how i set the screw.

Share this post


Link to post
Share on other sites

You should be at least 1 turn out. Your adding air the more u turn out. If your running best at .5 turn with the 45 try a 47. Your adjustment on the air screw should be between 1 to 2.5 out. Less then one pilots too lean. More then 2.5 too rich. I assume u put the 50 in? When was the last time the muffler packing was replaced?

Share this post


Link to post
Share on other sites

Ya i put the 50 in it. Not sure on the muffler packing. Plannin on repackin it next weekend. Im on the road for work during week thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...