Jump to content

Kawasaki KFX 90 starter not working...please help

Recommended Posts

Hi. I'm new as a forum member to TT, but have been reading articles and learning a lot for a couple years now. This one has me stumped. My son's 2007 kfx 90 will start fine when kick started, but the start button only starts it very intermittently. Battery is new and has 12v. I know the starter is good, because if I bypass the starter relay (jump the wire that has 12v to the one that goes to the starter) it starts right up. This led me to believe it was the starter relay. Replaced and still won't work! I tested the push button itself and I get continuity when I push it. I tried jumping the two wires that go to the push button, just to be sure, no start, so this should mean that it isn't the push button right? I have two wires, a yellow/red and a green that come from the push button and I think they go the starter relay (same colors, although green wire is slightly different) I tried jumping those each (from push button to starter relay connector) and no start... So I have a new battery, a new starter relay, a starter that I've confirmed works, I think the push button is working. Any other ideas? Any help is appreciated. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×