Jump to content

07 Wr450 Supermoto Problems.. Please help

Recommended Posts

Hows it going guys! I just got a supermoto about 2 months ago and have been tinkering away. Today after installing new jets and completely cleaning carb and rebuilding it I've had some issues.

 

At wide open throttle there isnt a problem but at constant throttle I get a feeling like the bike misses and i lose power for a split second ( kind of like a sputter/surge ). Felt it while i was riding on the highway. Current elevation is around 500', humidity is around 85%, and temperature today is 60-70d F. I also had some trouble turning it on yesterday after a ride, turned on with hot start only. TPS disconnected and grey wire disconnection has been done.

 

Current jetting specs:

2007 wr450

170 main

48 pilot

Leak jet plugged

Jd red needle 5th clip down

Every other jet is stock

Fuel screw is 2 turns out from completely closed

 

Any idea what it can be?

 

Thanks for the help!

Share this post


Link to post
Share on other sites
On 2/14/2017 at 1:19 PM, William1 said:

Try the needle on clip 2 from the top/flat, let us know if there is a change. Also, get the TPS calibrated and connected.

Going to try that this weekend. Do you know why fuel is leaking out of the vent hose? It started doing that when I put the blank leak jet. Does it when i blip the throttle, does not happen when bike is shut off.

Share this post


Link to post
Share on other sites

Leak jet/AP mods should have nothing to do with fuel dripping. Perhaps the float is not sitting right, or you accidentally bent the float tang or there is a smidge of debris in the float needle seat.

Be sure the petcock is CLOSED when not riding.

Share this post


Link to post
Share on other sites
18 minutes ago, William1 said:

Leak jet /AP mods should have nothing to do with fuel dripping. Perhaps the float is not sitting right, or you accidentally bent the float tang or there is a smidge of debris in the float needle seat.

Be sure the petcock is CLOSED when not riding.

Thank you for the help. Will be tearing it apart again this weekend and checking it.

Edited by motonoobwr

Share this post


Link to post
Share on other sites

its too rich,needle fer sure,not sure why you have tps disconnected,I would reconnect,45-48 pilot, 2-1/2 on fuel screw ,make sure the o ring and washer are there on fuel screw,165 on main, they like to run super lean. if you have slow speed crackle see my post on that subject,put heavy oring or wire over little black lever /fuel acc pump screw (under throttle cable cover) you can screw the adjuster screw all the way in to start for full fuel pump action.

assume you have air box  opened up and straight pipe

Share this post


Link to post
Share on other sites

its too rich,needle fer sure,not sure why you have tps disconnected,I would reconnect,45-48 pilot, 2-1/2 on fuel screw ,make sure the o ring and washer are there on fuel screw,165 on main, they like to run super lean. if you have slow speed crackle see my post on that subject,put heavy oring or wire over little black lever /fuel acc pump screw (under throttle cable cover) you can screw the adjuster screw all the way in to start for full fuel pump action.

assume you have air box  opened up and straight pipe

buy new float needle from yam ,they are 15$,set float so it is level with carb body when it first touches the float,best to hold carb sideways when doing it, not upside down as float will compress float needle spring.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×