Jump to content

Crf250l led turn signals

Recommended Posts

Hey guys I just installed drc fender eliminator and 601 turn signals and other than the fast flashing everything works right, when I go to do the front ones the lights won't blink if I attach the oem turn signals at the same time as the leds they flash just fine. Came to the conclusion that the leds in the front don't pull enough power to blink on there own. What can I do to fix this I don't mind the fast rate flashing I just need them to come on. Currently all four leds wired in and no flashing.

Share this post


Link to post
Share on other sites

LEDs don't draw as much as bulbs, so if you add a pair, it flashes fast, if you add all 4 LEDs, it won't flash at all, not enough draw.  You can add a constant rate  flasher, but even then the indicator on the insturment pannel won't flash, just goes bright to dim.  I did LEDs on mine, used the Constant rate flasher, which works, but then added a pair of resistors to the rear signal circuits to allow the indicator to actually flash properly in the cluster.  I do miss the noise from the stock flasher relay(CR flasher is silent), helps remind me to cancel the flashers, tried adding 4 resistors, but still flashed too fast, so I gave up, would need to match the resistance of the stock bulbs.  Now that the 2017 250L has LEDs, I'm hoping I can use the new OE relay to restore the audible function when used with LEDs.

  • Like 1

Share this post


Link to post
Share on other sites

I got the flasher relay from 12 o'clock labs and everything including dash light works properly. No extra resistors, all plug and play.

  • Like 1

Share this post


Link to post
Share on other sites
Came to the conclusion that the leds in the front don't pull enough power to blink on there own.
#1 on comment by Evan D. My entire setup is also from 12 o'clock labs and it works flawlessly. Same with many others on this forum over the years. Call 12 o'clock and tell them your issues and they will help you figure it out.

Share this post


Link to post
Share on other sites
11 hours ago, charcoalford said:

Hey guys I just installed drc fender eliminator and 601 turn signals and other than the fast flashing everything works right, when I go to do the front ones the lights won't blink if I attach the oem turn signals at the same time as the leds they flash just fine. Came to the conclusion that the leds in the front don't pull enough power to blink on there own. What can I do to fix this I don't mind the fast rate flashing I just need them to come on. Currently all four leds wired in and no flashing.

Most people just buy this .......    http://www.crfsonly.com/catalog/product_info.php/cPath/290_294/products_id/5149

Fixed Rate Turn Signal Flasher
This device is plug and play, as well as universal; designed to work for any motorcycle with a DC electrical system (such as Yamaha, Honda, Kawasaki, Suzuki, etc) (There are a few KTM & Husqvarna enduro models that do not use DC for the turn signals, but can be modified to use DC) This device comes with the mating connector set, so it can be wired in for custom applications if needed.

OEM Connector
The Fixed Rate Flasher is a direct plug-in replacement for the following OEM part numbers:
Yamaha OEM Part: 4MY-83350-01-00
Honda OEM Part: 38301-MBW-D21
Kawasaki OEM Part: 27002-0006, 27002-1091, 27002-1097
Suzuki OEM Part: 38610-26E00

Product Details
You may have noticed after adding aftermarket turn signals your blink rate has significantly increased, OEM flashers are designed for standard bulbs which draw a few watts each, much more than typical aftermarket bulbs or LED signals. This device is an effective alternative to using load resistors, it consumes considerably less watts, consumes less space, and does not generate excessive heat.
 

Direct Plug & Play OEM Replacement.

Smaller & less weight than OEM.

Fixed Flash Rate, not load dependant.

Flashes at the DOT OEM flash Rate.

Works for LED or Standard Bulb Turn Signals.

All Solid State design.

Meets or exceeds OEM load rating specifications.

Designed with 500,000 life hour solid capacitors.

Will blink even with extremely low loads, down to 0.1W / 0.01A

 

 

12oclocklabs-honda-crf250l-fixed-rate-tu

Share this post


Link to post
Share on other sites
5 hours ago, Evan D said:

I got the flasher relay from 12 o'clock labs and everything including dash light works properly. No extra resistors, all plug and play.

Weird, I used a set of 601s, constant rate flashers, and O.E. connector kits, all from 12:00 labs.  With everything plugged in it flashed correctly, except for the dash indicator.  after flashing to full brightness, it slowly dims, then flashes bright again with the turn signals every couple seconds, turn off the flasher and took about 2 seconds to dim till it went out.  Adding an O.E. light in the circuit or even a small resistor made it flash on and off correctly.  Mine is a '16, not sure if they changed anything, another CRFer locally with the same year had the same issue and same cure.

Edited by alucard0822

Share this post


Link to post
Share on other sites

Since I got my bike, have installed High Tech Speed Proton Led flush mounts on the front and rear Blade light, didn't add anything else, just wire it up and go. Very bright and visible. Never a prob, slim and sano, nothing to break off. Not sure why everyone needs all these extra doo dads for their lights.

Edited by hockeyrick

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×
×
  • Create New...