Jump to content

Clutch crutched

Recommended Posts

I have a 03 kx125, just put a new barnett clutch and motion pro cable on it today but cannot seem to get the adjustment right. When adjusted where I like it in the lever it wants to pull when placed in gear, to get it not to do so its adjusted all the way out at both ends ( like one thread holding). What am I doing wrong? Cable placement? Wrong cable? Rookie signs? All the above?

Share this post


Link to post
Share on other sites

I find that with things like warped plates or mismatched ones.  The type of fluid if you changed is another.  If you didnt change springs or if the new ones aren't length matched etc.  Sometimes the holes the springs ride in wear unevenly.  Sometimes it gets a little or alot better with an hour or two of riding.   

Share this post


Link to post
Share on other sites

Your lever should have a certain amount of free play. Are you adjusting the lever to meet the spec? If the free play is correct and the clutch is dragging, you have some worn components.

  • Like 1

Share this post


Link to post
Share on other sites

I dont know the spec, I like a little play in my lever, when its where I like it it pulls, to get it to stop its unscrewed all the way out or vise versa on the other end of the cable

Share this post


Link to post
Share on other sites

The manual will give a method of measurement. I don't remember where I heard it from, but when I was a kid I was told you should have enough free play to fit a nickel between the lever and perch. Don't overlook the pushrod and arm as possibly worn parts.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×