Jump to content

Xl won't start

Recommended Posts

I have been trying to start a 1980 xl500 recently and the thing won't even fire. The carb was just rebuilt and it has great spark and I sprayed starting fluid in to try to get it to pop. The bike feels like it has low compression but I feel like it would still start. I am about ready to set the thing on fire

Share this post


Link to post
Share on other sites

Who did the carb "rebuild"?

Was the fuel screw removed and that passage cleaned? A rebuild would have included a new oring for it.

How old is the fuel?

Have you tried pull starting it?

Share this post


Link to post
Share on other sites

Not enough info on the history of the bike. If it's been a barn queen for the last 20 years, there is a whole list of things one could come up with.

Share this post


Link to post
Share on other sites
5 hours ago, 4strokeridertt said:

I would bet that either a valve seat got corpus (corroded) and isn't dealing (sealing)or the valves are a bit right (tight) and not allowing enough compression.

you got to stop with the drugs

 

Share this post


Link to post
Share on other sites
1 hour ago, Tryingoutdirt said:

you got to stop with the drugs

 

Typing into a phone with a dog jumping all over me to play really did allow spell check to make a mess of things.

Not sure how the heck you understood what I was saying. Good Job.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×