Jump to content

XR100R throttle not fitting back together! What's the problem?

Recommended Posts

Hey guys!

I own a 1998 XR100R, non-California edition with carburetor PD80C. I loosened the carburetor cap on top to take off the whole carb because I'm going to rebuild it, because I think it's the main reason my bike won't run. The problem is, I can't get it to screw back on. I took a look at the service manual and it almost looks nothing like my throttle! The cable is in a different position, the needle falls right out if I move the throttle valve, and the spring is all bent up. One time I did get it to screw back on but the throttle was extremely easy to move and it was sticking.

I took some pictures and a video. They are attached here.

Video: (Not sure why it repeats.)

 

IMG_20170326_142324.jpg

IMG_20170326_142329.jpg

If more pictures are needed, then just ask!

Share this post


Link to post
Share on other sites

Are you installing the slide backwards.........?  The cutaway on the bottom of the slide goes to the back.  Slot in slide to the left and lined up with the guide pin in carb.

Old School Al

  • Like 1

Share this post


Link to post
Share on other sites
1 minute ago, Old School Al said:

Are you installing the slide backwards.........?  The cutaway on the bottom of the slide goes to the back.  Slot in slide to the left and lined up with the guide pin in carb.

Old School Al

Slide? As in the throttle valve (the black piece)? I didn't realize there was a guide pin for it... I'll go take a look at it again.

Edited by Sumoguy12

Share this post


Link to post
Share on other sites
Just now, Old School Al said:

Get it figured out...................?

Old School Al

Yep, as a matter of fact I did! Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×