Jump to content

gearoilemulsified 2014 Beta 350 RR

Recommended Posts

Hi all I've recently bought a used Beta 350 RR the bike is in great condition and has been very well looked after by the former keeper a friend of mine. 

I have found I'm getting water into my gear oil after doing the shallowest of water crossing and finding my self is some wet bog land. I don't believe the water is coming from the coolant as the radiator water level has never dropped I've had other bikes and done much deeper river crossing and never had this problem.

Any advice would be greatly appreciated as my mechanical knowledge is slim to none.

 

thanks in advance

 

Drew

Share this post


Link to post
Share on other sites

The first place to look is the gear box vent, it might be defective or it might need an extension.

Share this post


Link to post
Share on other sites
13 minutes ago, agave248 said:

The first place to look is the gear box vent, it might be defective or it might need an extension.

By the gear box vent do you mean the black blow off hose/pipe or am I mistaken for something else? 

Share this post


Link to post
Share on other sites
8 minutes ago, agave248 said:

I would also check if the cap is loose or has a bad seal.

Great idea for the seal. I have always made sure it's nipped up but never actually checked the o ring 

Share this post


Link to post
Share on other sites

Not sure how your bike is set up exactly, the vent is usually a rubber hose on the top of the transmission. It could be other things but this a good place to start. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×