Jump to content

Well.....this sucks

Recommended Posts

So ihave been doing some work to a 2002 cr80 and it has been giving me a world or troubles, like you would not believe. So long story short I fund a good deal on a cylinder and head and everything and put it all together not really thinking much, just taking things slow trying not to mess anything up. just want this thing out of my garage. so when I had the head all on and everything like that I went to put the coolant hoses on and one of the ports on the head is different?!?!?! its off to the side not facing the back of the bike. I thought about it didn't think about the pipe and just made a piece of hose work. when I went to put the pipe on....didn't work. SO whats going on here. I'm stumped. I didn't realize there was more then one style of head. NEED HELPPPPPPP

Share this post


Link to post
Share on other sites

Sounds like you bought a cylinder and head for a different year of bike than what you have. I'm not sure when changes were made from year to year but you can research parts schematics online and try to determine what year parts you bought. Don't jury-rig things together. Get the right parts.

Share this post


Link to post
Share on other sites
4 minutes ago, Dklassen said:

Sounds like you bought a cylinder and head for a different year of bike than what you have. I'm not sure when changes were made from year to year but you can research parts schematics online and try to determine what year parts you bought. Don't jury-rig things together. Get the right parts.

trust me when I say this. havnt "jury-riged" anything. this bike is gorgeous. upon further research the head I got is from 96 and back. So. Buying another head it is.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×