Jump to content

DRZ 400 brake light issues

Recommended Posts

i have a 2002 drz400s with the stock tail light. the running light works but when i go to press the brakes the light doesnt get brighter. ive changed the bulb out and it is still the same. when i turn the parking light on the light does get brighter. ive tried jiggling around some wires but no luck. ive read some other threads saying it could be a switch but im not sure on how to check if the switch is bad.

Thanks in advance

Share this post


Link to post
Share on other sites
20 hours ago, metalpedal199 said:

i have a 2002 drz400s with the stock tail light. the running light works but when i go to press the brakes the light doesnt get brighter. ive changed the bulb out and it is still the same. when i turn the parking light on the light does get brighter. ive tried jiggling around some wires but no luck. ive read some other threads saying it could be a switch but im not sure on how to check if the switch is bad.

Thanks in advance

Very likely one of the brake switches. There is one switch by the brake pedal (look under the bike) and one on the brake lever. They are normally open but should close when you activate the brakes. Check to make sure the switches move when you move the lever or pedal. If they do trace the wire back to the plug on the harness and use a multi-meter to check that the resistance goes to zero on the switch when closed.

Here is a DRZ400 wiring diagram from another thread on TT.

 wiring diagram drz400s-sm.05on.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×