Jump to content

dr650 vibration

Recommended Posts

Okay, me and my dad just got new dr650"s his is a 2016 and mine is a 2017, my bike vibrates allot more than his, it is engine vibration, and his has 166 miles and mine has 240 so my bike is technically more broke in but vibrates more I have checked motor mount bolts and all exaust bolts/ fittings and made sure carb clamps are tight, what else do i do? And the clutch is also much rougher on take off than the 16, so whats my problem? Also i dont know if this makes a difference but my dads bike is on the lowered setting for height 

Edited by yz400fmaniac

Share this post


Link to post
Share on other sites

As you posted, the height setting isn't doing anything.

Vibration wise, is it vibration at idle or going down the road?  Either way, with so few miles I'm sort of thinking that the valves just aren't sealed yet and that's leading to an idle vibration.  If it's happening when your going down the road then you need to make sure that the wheels are correctly balanced and that the internal counter balancer is correctly times.

Make sense?

Share this post


Link to post
Share on other sites

Ok zig06 thanks for reply it has little vibration at idle and most of the bad/ rough vibration is at 1/4th throttle to 1/2 throttle than it is fine/ smooth vibrations I now have 447 miles on it and it is going into the dealer because it is crackling fairley bad on decel whitch means its lean well leaner than its supposed to be anyway and also cushdrive has about 1/4 inch back and forth play but I am really starting to think i got a lemon, my dads bike is butter smooth at any speed and any rpm and when going down the road if i pull the clutch in and rpm's go down there is no vibration

Edited by yz400fmaniac

Share this post


Link to post
Share on other sites

I just did the first service on mine, and it seems to run smoother. I don't know what type of oil was in it from the dealer, but I put Pennzoil 10/40 in it. But I didn't have any excessive vibe. to begin with.    joe 

Share this post


Link to post
Share on other sites

To central joe, my dad and I both did first service at 220 miles, his bike has been smooth as silk since he bought it mine has ben rough so somethings wrong i just dont know what ill post what i find out im betting theres something wrong with the carb 

Share this post


Link to post
Share on other sites

I personally would install a jet kit in both bikes "just because".  Then again, I did install an FCR on my '03 DR650 (almost up to 30,000 miles!) which totally blows the stock carb out of the water.

You should also seriously consider cutting the top of your air box (aka "snorkel removal") and re-jet.  You can leave the stock muffler on there, being in stealth mode does have advantages.  With both of those (jetting and air box mod) your DR will run like you expected it to before you even rode it.

Get your jet kit here:  https://procycle.us/bikepages/dr650.html#fuelsystems

 

Share this post


Link to post
Share on other sites

Zig06 i totally agree but i cant for 1 yr, only because i dont want to boid warranty and after these problems i thinki will need my warranty on this bike other than the vib and now the cush drive problem i really love the bike. Sorry about spelling wrote this on tiny iphone 5s and have fat fingers lmao

Edited by yz400fmaniac
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×