Jump to content

drz only runs cold

Recommended Posts

Hey all, any advice? My 03 S model starts right up cold and runs great for about 5-10 min then shuts down and won't start for anything for a few hours, then repeats. It started when i accidently left fuel on overnight and it flooded. There doesn't appear to be any gas in the oil. Again it fires right up after sitting just won't stay running. Is it possibly a coil issue? Could it just be a coincidence I flooded  it? Bike has 15K miles recently rejetted with JD kit for 3x3 and FMF full system and ran flawlessly until this problem surfaced. Thanks in  advance, Adam

Share this post


Link to post
Share on other sites

 I have had the same exact issue with my DRZ,  as well as numerous others on this form over the last year I've been here. 

 First thing I would do is pull your dipstick and see if you smell gas, if you do swap out the oil for fresh and see if the issue is still there. Chances are it will go away at which point you will need to troubleshoot the issue of contaminated oil. 

 Normally for these bikes that is either a bad petcock, or a bad oh ring on your needle seat allowing gas to overfill the float bowl and run into the crank.

Edit: Do you have a vaccume petcock, or an aftermarket one? Also is this the stock BRS36 carb or did you swap it out?

 

Edited by RC_ichard

Share this post


Link to post
Share on other sites

For the price of an oil change - just assume the oil is contaminated with fuel and change it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×