Jump to content

yz125 bogs and backfires

Recommended Posts

The other day I was riding my 1995 yz125, I stopped to take a break and leaned the bike against a tree and turned the gas off so it didn't flood, when I went to start it again it started first kick like always and idled fine but when I gave it gas it bogged and died. It wouldn't start after that so I push started it and it started but when I gave it gas it bogged and backfired. I have no idea what is wrong, please help! Thank you!!!!! 

Share this post


Link to post
Share on other sites
Reeds are probably worn out , have you checked them lately ?
 

about to check those now. how would I know if they are bad?

Share this post


Link to post
Share on other sites
5 hours ago, Chase Q said:

plug looks fine


plug looks fine

big help.  best of luck.

  • Like 1

Share this post


Link to post
Share on other sites

If you have to shut the fuel off every time you stop then the needle and seat are bad.

If the reeds are chipped or there is a gap between them and the block they are bad.

Have you done a compression test?

What color is the spark plug?

Share this post


Link to post
Share on other sites

he said it was fine.  layoff of him:rant:

Edited by ossagp

Share this post


Link to post
Share on other sites
If you have to shut the fuel off every time you stop then the needle and seat are bad.

If the reeds are chipped or there is a gap between them and the block they are bad.

Have you done a compression test?

What color is the spark plug?


the plug is not completely black, just at the end. spark still gets through to it

Share this post


Link to post
Share on other sites
Reeds are probably worn out , have you checked them lately ?
 

I checked the reeds, there doesn't seem to be any chips and there isn't a gap

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×