Jump to content

YZ250 water leaking?

Recommended Posts

08 YZ250

Exhaust pipe needs tweaking so it seats good to the cylinder, so I was cleaning all the goo off the bike this morning to take it to a pipe repair guy.  Noticed when I was cleaning around the PV side cover that I was getting a drop of water coming out of that cover, right at the end of the plastic gaskety thing that goes between the cover and the cylinder.  I would wipe it away and a few minutes (sometimes seconds) later I would see a new drop form and it would run down the front of the motor.  Looked perfectly clear like pure water.

Recent cooling issues:

1.  Doing trail prep a couple of weeks ago for a big event and out on the trail I had a radiator hose split and the bike got really hot before I realized it.  Fixed it in the woods enough to finish the day.  Replaced all hoses with new ones and even installed new radiators as the ones I had were bent a bit.  Filled with new Engine Ice.

2.  During the ride this past weekend I was out in the middle of nowhere pulling down arrows, and my shifter stripped so I couldn't shift gears.  Had to do pretty much everything in 3rd gear (thank God for Rekluse) but it caused the bike to overheat and spew coolant quite a bit.  On the trail I refilled my radiators with a bottle of water, had been full of Engine Ice.

Now I get this weird water drip.  I haven't taken that side cover off the PV linkage yet, but I will later today.

Is this a normal place to get a water leak??  Doesn't seem to make sense to me to have water up there, but maybe I'm not thinking about it right.

Rebuilt the motor, top and bottom, last winter.  One of the few things I didn't do was rebuild the water pump assembly....starting to think that was a bad idea now.

Share this post


Link to post
Share on other sites

I doubt the drip of water is related to the rest of the story. It's coming out by the big rubber gasket between the linkage cover and the right side case? Probably from washing the bike? Any unusual stream crossings lately? Long ride in the rain? I put my money on washing! Pop that side cover off and have a look. Make sure everything fits proper when it goes back on.

  • Like 1

Share this post


Link to post
Share on other sites
I doubt the drip of water is related to the rest of the story. It's coming out by the big rubber gasket between the linkage cover and the right side case? Probably from washing the bike? Any unusual stream crossings lately? Long ride in the rain? I put my money on washing! Pop that side cover off and have a look. Make sure everything fits proper when it goes back on.


Ok good to know! I'll pop it off and I bet you are right. I've just never spent much time looking around there after washing so just never noticed it before. I guess all my recent cooling incidents had me worried I had cooked something.
  • Like 1

Share this post


Link to post
Share on other sites

I would highly recommend a water pump rebuild, not necessarily because it's the problem, but because it's a good maintenance idea. Plus if you're doing the rest of the cooling system, then you might as well. It's a 1-1.5 hour job if you know enough about wrenching. Good luck!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×