Jump to content

issues after removing stator case

Recommended Posts

Hello TT, hopefully someone can shed some light on the mistake i made while attempting to replace the gasket behind the stator cover and then changing the oil.

I removed the case then the old gasket placed the new one in and then sealed her back up fill her with about 1.8L of new moil. Let the bike sit. then i tried to start it and this is what i got.

https://drive.google.com/open?id=0B88B9EhVqIu5aVJxXzJMZVVjNTA

Share this post


Link to post
Share on other sites

Yea the bike was basically empty of oil when I changed the stator gasket. I drained the frame, then the bottom of the engine (under the skid plate) and then from the oil filter area. After the repair I then refilled with about 1.8-9 liters of oil

  • Like 1

Share this post


Link to post
Share on other sites
Hello TT, hopefully someone can shed some light on the mistake i made while attempting to replace the gasket behind the stator cover and then changing the oil.
I removed the case then the old gasket placed the new one in and then sealed her back up fill her with about 1.8L of new moil. Let the bike sit. then i tried to start it and this is what i got.
https://drive.google.com/open?id=0B88B9EhVqIu5aVJxXzJMZVVjNTA

Video won't play, can you describe the issue?

Share this post


Link to post
Share on other sites

There is a clicking sound when i start the bike sounds like its coming from the stator case

3 hours ago, Backwoods-Bomber said:

Video won't play, can you describe the issue?[/r replacing the static gasket there is a clocking sound
Edited by DRZ _SWOOZ

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×