Jump to content

No electrics Wr450f 2004

Recommended Posts

Hey all, I've recently brought a wr450f 2004 model and none of the electrics work, I've purchased a new battery and changed the 3 10amp fuses under the seat and nothing changed, it has power past the solenoid and is charging when running, relay clicks when pressing the start button but nothing happens. I've just got back into riding after a way too long break. It wouldn't worry me too much but the kick starter is savage on the old foot and makes hill starts a nightmare, I'm going to get it registered this year and get my license so I need to sort it out eventually anyways.

Any suggestions will be much appreciated.

cheers all

Share this post


Link to post
Share on other sites

And also there are TWO 10A fuses under the seat, not three.  

Only one is active, the other one is a spare and is not connected to anything.

If the small relay near the rear fender clicks but not the solenoid (the one the large battery cables are connected to) then that solenoid could be dead.   Assuming your battery is good you can test it by using a screwdriver to jump across the two 8mm bolts on the solenoid.   Starter turns, starter motor is good, solenoid is dead.   No action, starter is done.

 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks guys, well welcomed wisdom

Ok so I can see the battery charging with a multi when going so figure the stator is working(correct me if I'm wrong) 

The starter works when I bridged the two 8mm bolts.?

 I can also hear a click at the relay near the rear guard when I press the start button.

ill grab a new solenoid this week ??

Thanks again 

 

Share this post


Link to post
Share on other sites

Check to make sure either the clutch safety switch or neutral safety switch are functioning properly.  Without at least one of those working, the starter relay (where the fuses are) won't receive power or function.

  • Like 1

Share this post


Link to post
Share on other sites

Ended up being the relay near the rear guard. Was clicking but was buggered.. $6.50 and I have electric start ☺️ My foot was that bruised from kick starting, so glad that's sorted.

Still have no power to my lights or blinkers but I can go riding tomorrow so I'll look into that after the weekend!

thx all who replied, it was very much apprecited??

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×