Jump to content

KX250 new brake pads rubbing?

Recommended Posts

Just put new pads & rotors on my 02 KX250. Stops amazing! however after a short ride and running the pads in some, the fronts are dragging some. Nothing horrible and still spins by hand. You'll get say 2 rotations before it stops free spinning. 

So do they just need to wear down some - or some other issue? 

 

No dragging before hand, other than a slightly bent rotor.

Share this post


Link to post
Share on other sites

The pads wearing will not resolve the issue, the brake system is self adjusting. Did you bleed the brakes after you installed the new parts? When you push the piston into the caliper you will introduce some air into the system and it will need to be bleed. What you can also try is to crack loose the caliper mounting bolts, spin the wheel a few times and hit the brakes, after a few times spin the wheel and hold the lever while you tighten the bolts. That will help align the caliper with the rotor. The pads should be in slight contact but the wheel should spin more than 2 revolutions.

  • Like 1

Share this post


Link to post
Share on other sites
11 hours ago, GasMixer44 said:

The pads wearing will not resolve the issue, the brake system is self adjusting. Did you bleed the brakes after you installed the new parts? When you push the piston into the caliper you will introduce some air into the system and it will need to be bleed. What you can also try is to crack loose the caliper mounting bolts, spin the wheel a few times and hit the brakes, after a few times spin the wheel and hold the lever while you tighten the bolts. That will help align the caliper with the rotor. The pads should be in slight contact but the wheel should spin more than 2 revolutions.

Perfect I'll give that a try

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×