Jump to content
Sign in to follow this  

PW50 Won't start

Recommended Posts

Hello everyone, I am hoping that someone can help me sort out why my PW50 won't run. I bought it for $150 not knowing why it wouldn't run but assuming I could get it to. It is a 2001, so not the latest generation which started in 2002 I believe (though almost nothing has changed).

It is getting not spark that I can tell, I initially was just going to put in a new stator and hope that did the trick as I have heard they go out in these pretty regularly, but I was sent the part for the newer PW I believe because the plugs don't line up, but everything else does. Not wanting to get the wrong parts again I just went ahead and ordered the Black Dragon full ignition system from PW'sonly. I still have no spark, or honestly even any idea if I installed it correctly, there is nothing that I can find as far as instructions on how to install it, what stock parts to keep with it, or anything. Overall I am very unimpressed with the amount of info out there on PW50's. I have completely gone through and rebuilt several bikes, but I am finding that I know next to nothing on these little things.

Any help is appreciated!

Share this post


Link to post
Share on other sites

Have you checked the ignition coil for sure to tell if you are getting any spark? Is the ignition switch wired up correctly?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...